Skip to content

Available Software Versions - Debian 9 (Stretch)

If you plan to upgrade operating system to Debian Stretch, either of your own accord, or because you were advised to do so by one of our employees, you need you decide which versions of software are you going to use. This article contains a list of software versions available in Debian Stretch.


The only available version is 2.4. Other versions cannot be installed. Details about incompatible changes are available on the Apache web server website. One of the most common sources of problems is the new access management module. That can be solved by installing mod_access_compat.


  • 6.x ( EOL 11/2020 )
  • 7.x

By default, we install the latest version available in developer’s official repository. There are no incompatible changes between minor versions.


  • 1.7
  • 1.8 - recommended
  • 2.0

HAProxy’s configuration is usually compatible even between major versions. In some cases, slight changes are necessary. However, those are done by our administrators as part of the upgrade process. Only in case you provide your custom configuration, you need to update it yourself.


  • OpenJDK 8 - recommended
  • OpenJDK 11
  • OracleJDK 9 - license required!


  • 1.4

We recommend to replace this outdated software with Nginx. We do not support Lighttpd on fresh installations.


  • 2.x
  • 3.x
  • 4.x

ManticoreSearch is database for full-text search. It is the successor to SphinxSearch, version SphinxSearch 2 is compatible with ManticoreSearch version 2. When migrating to ManticoreSearch version 3, the index_converter configuration migrator can be used.


  • 3.6 - recommended
  • 4.0
  • 4.2

Normally, we would recommend version 3.2. However, it is already EOL and only supported by distribution maintainers. Therefore, if compatible with your application, we recommend version 3.6 directly from the developer’s official repository. Versions 4.x are also stable and do not cause problems in production.

MySQL / MariaDb

  • MariaDB 10.1
  • MariaDB 10.2
  • MariaDB 10.3 - recommended
  • MariaDB 10.4

MariaDB is a fully compatible substitute for MySQL. In 10.2, there was a number of changes that cause invalid SQL queries to fail (typically an insert that does not contain a value for a column without a default one). Due to that, older applications, written against MariaDB 10.1 and earlier, often do not work. If possible, we recommend updating the application. But if that is not feasible, MariaDB 10.3 can be set to compatibility mode with performance loss. We recommend version 10.3, which enables seamless upgrades to Debian Buster. Version 10.1 is EOL in October 2020, so we strongly discourage its use in fresh installations.


  • 1.10 - recommended
  • 1.12
  • 1.14

We install stable versions only. In our experience, the mainline versions (odd numbers) are not suitable for use in production environments.


  • 8
  • 10
  • 12


  • 2.4

This version is compatible even with older clients.


  • 9.6 - recommended
  • 10
  • 11
  • 12

Upgrades usually go without complications. There are few incompatible changes between versions. If you are using an older version, please check the support policy on the project’s website


  • 5.6 - the oldest version available for install (not as Apache module on Plesk servers)
  • 7.0
  • 7.1
  • 7.2
  • 7.3
  • 7.4 - recommended, if compatible with your application

You can find the details about versions’ life cycles on the PHP website. To ensure the security of your applications, use only supported versions!


  • 3.6
  • 3.7


  • 3.2 - recommended
  • 5.0

Redis 4 and higher in cluster mode are incompatible with older clients and applications. 


  • 2.2


  • 5.0

Varnish configuration is always provided by the customer, because it must be tailored to their application. If the configuration format has changed between versions, you need to send an updated configuration before the upgrade. We install Varnish only in cases, where the application’s performance is unacceptable without it.