Debian Stretch - dostupné verze software

Technicka podpora
2019-05-29 14:05

Pokud se sami rozhodnete pro distribuční upgrade operačního systému na verzi Stretch nebo je Vám takový upgrade doporučen našimi pracovníky, je třeba definovat verze softwaru, které se rozhodnete na serveru používat. V tomto článku jsou definice dostupných verzí softwaru v distribuci Stretch.

 

Apache

Dostupná je výhradně verze 2.4, jiné verze nelze na server instalovat. Informace o nekompatibilních změnách jsou dostupné na stránkách projektu Apache Webserver. Mezi nejčastější komplikace patří nový modul pro řešení oprávnení - tuto situaci lze vyřešit instalací a aktivací modulu mod_access_compat.

 

ElasticSearch

  • 5.x
  • 6.x

Standardně instalujeme poslední verzi z vybrané řady přímo z repositéře vývojářů. Tyto minor verze neobsahují nekompatibilní změny.

 

HAProxy

  • 1.7
  • 1.8 - doporučujeme

Verze haproxy mají konfiguraci obvykle kompatibilní. V některých případech je třeba konfiguraci upravit. Jedná se ale o úkon, který v rámci upgradu provedou naši administrátoři. Pouze v situaci kdy kompletní konfiguraci haproxy dodává sám zákazník je nutné, aby konfiguraci dodal sám.

 

JAVA

  • OpenJDK 8 - doporučená verze
  • OpenJDK 9
  • OracleJDK 9 - pozor, vyžaduje licenci !

 

Lighttpd

  • 1.4

tento zastaralý produkt doporučujeme při upgradu nahradit webserverem nginx. Na nové instalace tento produkt již neinstalujeme

 

MongoDB

  • 3.2 - doporučená verze
  • 3.4
  • 3.6
  • 4.0

Pro zajištění stability projektu doporučujeme instalovat distribuční verzi 3.2. Dle našich měření je performance v celé řadě 3.x v podstatě totožná a pří testech které jsme prováděli byly rozdíly na úrovni chyby měření.

 

MySQL / MariaDb

  • MariaDB 10.1 - doporučená verze
  • MariaDB 10.2
  • MariaDB 10.3

MariaDB je kompatibilní náhrada za MySQL. Pro instalaci doporučujeme verzi 10.1 ( ekvivalent mysql 5.6 ), novější verze obsahuje řadu restrikcí na úrovni SQL jazyka, které jsou sice z pohledu databáze správné, ale s velkým množstvím aplikací je tento režim nekompatibilní.

 

Nginx

  • 1.10 - doporučená verze
  • 1.12
  • 1.14

Instalujeme výhradně verze ze stable řady. Mainline řada ( liché verze ) nejsou dle našich zkušeností vhodné pro produkční nasazení.

 

Node.js

  • 8
  • 9

 

OpenVPN

  • 2.4

Dle zkušeností je tato verze kompatibilní se staršími klienty.

 

PostgreSQL

  • 9.6 - doporučená verze
  • 10
  • 11

Přechod mezi verzemi bývá obvykle bez komplikací. Nekompatibilních změn je relativně málo. Pokud máte instalovanou starší verzi, sledujte dostupnost podpory pro instalovanou verzi na stránkách projektu.

 

PHP

  • 5.6 - nejstarší verze, kterou je možné na server nainstalovat ( není dostupné jako modul apache pro instalaci s PLESKem )
  • 7.0
  • 7.1
  • 7.2
  • 7.3 - tuto verzi doporučujeme, pokud ji aplikace podporují.

Detaily o životním cyklu jednotlivých verzí PHP najdete na stránkách projektu PHP

 

RabbitMQ

  • 3.6
  • 3.7

 

Redis

  • 3.2 - doporučujeme
  • 4.0
  • 5.0

Explicitně upozorňujeme na nekompatibilitu verze 4.0 a novější  v cluster režimu ze strany starších klientů a aplikací

 

SphinxSearch

  • 2.2

 

Varnish

  • 5.0

Pravidla pro Varnish vždy dodává zákazník, protože jsou na míru postavené jeho aplikaci. V případě upgradu ze starší verze se formát pravidel změnil a je nutné předat před upgradem pravidla v tomto novém formátu. Varnish instalujeme pouze v opodstatněných případech, kdy špatně napsaná aplikace bez externího cachování není schopna provozu.

 

Průměrné hodnocení: 3.67 (6 hlasů)

K tomuto záznamu nemůžete připojit komentář.