Proč neprovozovat více verzí PHP na jednom serveru

Technicka podpora
2016-06-14 18:33

Nejstabilnější způsob jak provozovat php je kombinace apache + php jako modul webserveru. PHP modul ale může být do webserveru pouze jeden. Další verze musí být provozovány v režimu fastcgi/php-fpm, kde dle našich zkušenostní stabilita není na úrovni modulu webserveru. Nativní podpora pro více verzí php v žádné, pro servery vhodné, linuxové distribuci neexistuje - důvodem je nedostatečná stabilita takového řešení a krátký životní cyklus PHP.

Technicky je sice možné zajistit běh více verzí PHP, prakticky to znamená obcházení všech nativních nástrojů distribuce a kompilování php ze zdrojových kódů a provozování jako fastcgi/php-fpm. Nevýhodou takového řešení je časová náročnost instalace i upgradů. Narozdíl od php z distribuce je při upgradu nutné nainstalovat novější verzi, které až nečekaně často přinese problém s kompatibilitou aplikací. Distribuční verze zůstává dlouhodobě stejná a opravovány jsou bezpečnostní a kritické chyby, což je pro stabilitu serveru a celého prostředí mnohem vhodnější.

Průměrné hodnocení: 0 (0 hlasů)

K tomuto záznamu nemůžete připojit komentář.